
 

CNC MASINJUHTIMISTARKVARA NCCAD7 

JUHENDMATERJAL 

 

Nccad7 juhendmaterjal koosneb 4 osast: 

 

1) CNC masinjuhtimistarkvara Nccad7 tutvustus; 

2) teksti graveerimine; 

3) pildi järgi joonestamine; 

4) positiivse reljeefi joonestamine; 

 

 

CNC masinjuhtimistarkvara Nccad7 tutvustus 

 

CNC masinjuhtimistarkvara Nccad7 on mõeldud CNC-tööpinkide juhtimiseks ja 

lihtsamate jooniste valmistamiseks.  

Nccad7 koosneb kahest peamisest osast: joonestamisosa ja CNC-pingi juhtimisosa. 

 

Tarkvara joonestamisprogramm koosneb erinevatest joonestusvahenditest ja joonise 

redigeerimise tööriistadest. 

CAM – freesimistehnoloogia seadistamise tööriistade menüü 

Settings – töölaua ja tööriistade parameetrite muutmine 

View – joonise vaadete suuruse muutmine 

Edit – joonise redigeerimine: liigutamine, kopeerimine, kustutamine 

Convert – joonte muutmine: lühendamine, pikendamine, ühendamine  

CAD standard – peamised joonestusvahendid: joon, kaar, ristkülik, 

teksti lisamine 

CAD special – vähekasutatavad joonestusvahendid: hammasrattad, 

kurvid, kaared 

CAD 3D – kolmemõõtmelise joonise joonestusvahendid 

Symbols – valmis joonestatud detailid ja nende redigeerimisvahendid 

Documentation – mõõtmete ja kirjanurga lisamise vahendid 

Information – informatsiooni joonise mõõtude ja koordinaatide kohta 



 

 

CNC-pingi juhtimisel lisatakse joonisele 

tehnoloogia ja seadistatakse tööpink. 

Pärast joonise valmimist lisatakse tehnoloogia.  

Safety distance – ohutu ala, kus võib frees 

vabalt liikuda 

Feed – freesi ettenihke kiirus 

Tool diameter – freesi lõiketera läbimõõt 

Entire depth – töötlemise kogu sügavus 

Depth per step – ühe astme sügavus 

 

Kõiki neid parameetreid peab programmi 

kasutaja teadma ja mõistma, et pink töötaks 

korrektselt.  

 

Tööpingi seadistamine: 

 frees liigutatakse algasendisse, lühikäsklus 

klahviga home; 

 freesi lõiketera pikkuse mõõtja seadistamine, 

frees liigutatakse pikkusemõõtja kohale 20 mm 

kõrgusele, salvestatakse  asukoht Ctrl+F12; 

 mõõdetakse freesi lõiketera pikkus, lühikäsklus 

F12; 

 määratakse töölaua nullpunkti, frees liigutatakse 

soovitud nullpunkti, kirjutatakse käsklus G54, 

lisatakse telg koos koordinaatidega. 

 



 

Teksti graveerimine 
 

Ava Nccad7 

Ava uus joonis File => CAD/CAM Milling – new 

drawing  

 

 

Pane paika töölaua nullpunkt 

Vali tööriist CAM menüü WORKPIECE ZEROPOINT 

 

 

 

 

 

Tee hiirega klikk töölaua vasakus alumises nurgas, jättes 

nurgast kummaltki poolt 10 mm. 

 

 

 

Kirjuta tekst graveerimiseks. 

Vali CAD standard menüüst ENGRAVINGTEXT max/sl. 

 

 

 

 

 

 

Tee hiirega klikk nullpunktist 10 mm 

kaugusele. 

 

Avaneb tekstiredaktor. 

Kirjuta soovitud teksti Batman, valite kirja stiili nt. 

KOSY ja kirja suuruse Point 24. 

Lõpuks vajutate OK. Töölauale tekib vasakusse 

nurka kiri. 

 

 

Freesimistehnoloogia seadistamine 

 

Vali tööriist CAM menüüst 

TECHNOLOGY. 

 

Tee hiirega klikk kirja juures 

oleval mustal punktil. Pärast seda, 

kui kiri on muutunud 

tumepunaseks punkt 1, liigu eemale ja tee klikk punkt 2 

juures. 

 

 

 

1. 

2. 



 

Avaneb tehnoloogialeht. 

 

Täida järgnevad lahtrid: 

 

Feed(F):  100.00 (*0,1 mm/s) 

Tool diameter  1.00 (mm) 

Entire depth  1.00 (mm) 

Depth per step  1.00 (mm) 

 

Kui märgitud, vajuta OK. 

 

Freesimise simuleerimine 

Ava Simulation => ZOOM automatic. 

 

 

 

 

 

Avaneb aken, kus küsitakse, kas 

simuleerida koos Z-teljega, vajuta Yes. 

 

 

Kui simulatsioon on lõppenud, ilmub kiri, kus 

küsitakse, kas protsessi on vaja korrata, kliki No. 

 

 

 

 

Järgnevalt tuleb tehtud töö salvestada, 

selleks vali File => Save as. Ilmub uus 

aken, kuhu tuleb kirjutada töö autori nimi, 

ja seejärel vajuta OK. 

 

 

 

 

 

 

Avaneb uus aken, kus tuleb anda tööle 

nimi ja salvestada soovitud kausta, 

lõpuks vajutada OK. Töö on salvestatud, 

nüüd jääb ainult freesida. 

 

 

 

 

 



 

Töö freesimine 
Töö freesimiseks vajuta Machine => CNC-Milling 

machine ja avaneb uus aken, kus tuleb alustada pingi 

seadistamisega. 

 

 

 

 

1. Vajuta klaviatuuril klahvi home - frees 

algasendisse. 

2. Vajuta klaviatuuril klahvi 

F12 – mõõdab freesitera 

pikkuse. 

3. Liiguta freesitera töölaua 

vasakusse esimesse nurka, 

nii et see saavutab kontakti 

freesitava toorikuga.  

4. Kirjuta akna all olevale reale 

punkt 3. => G54 X13.83. 

Number võtta punkt  4. 

juures olevalt väljalt. Vajuta 

klahvi enter ja punkt 4. 

juures olevad X-

koordinaadid muutuvad 0.00.  

5. Sama korrata ka Y- ja Z-telje 

juures. Rohelistel väljadel 

peavad kõik koordinaadid 

muutuma 0.00.  Nullpunkt 

on seadistatud. 

6. Nihuta freesitera nullpunktist 

eemale suvalise koha peale 

ja vajuta klaviatuuril klahvi 

end ja freesitera liigub uuesti 

nullpunkti. Sellega 

kontrollitakse, kas nullpunkt  

on õigesti seadistatud.  

 

Freesimiseks vajuta klahvi run punkt 5., avaneb uus aken, kus kontrolli järgnevat: 

 

1) freesitera kinnitatud; 

2) toorik kinnitatud; 

3) frees sisse lülitatud; 

4) freesi pöörded on õiged; 

5) nullpunkt on seadistatud. 

 

Freesimise alustamiseks vajuta Yes. 

 

 

1. 
4. 

5. 

3. 



 

Pildi järgi joonestamine 
 

Leida kahevärviline pilt, mida joonestada. 

 

Ava  File  => CAD/CAM Milling – new drawing  - 

avaneb uus tööleht. 

 

 

Pildi importimine 

Vali File => Import file => Picture-

file.  

 

Avanenud aknast tuleb valida sobilik 

pilt. Vajuta Open. Avada saab bmp, 

gif,  jpg pildi formaate. 

 

Seejärel kaob aken ja tekib siniste 

joontega kast, mis tähistab pildi 

suurust. 

 

 

 

Aseta pilt vasakusse 

alumisse nurka. 

 

Liigu hiirega vasakusse 

alumisse nurka punkt 

1.ja tee hiirega klikk, 

seejärel liigu hiirega 

eemale punkti 2. ja tee 

teine klikk, pilt tuleb 

nähtavale. 

 

 

 

 

 

 

1. 

2. 



 

 

Pildi vähendamiseks liigu  

hiirega Edit menüüsse ja vali 

tööriista SCALE.   

 

 

Järgnevalt märgi pilt ära: kliki 

vasakul alumises nurgas kujutise 

kõrval punkt 3. , liigu hiirega üle 

pildi paremasse ülemisse nurka ja 

kliki punkt 4.. Joonis muutub 

negatiivseks. 

 

Kliki uuesti joonise kõrval punkt 

3., liigu  hiirega eemale, nii et 

tekib rohelistest joontest kast.  

Kasti soovitav suurus on umbes 

60*40 mm.  Tee teine klikk. Pilt muutub uuesti 

positiivseks.  

 

Kasti suurust on hea vaadata töölaual olevate 

väikeste punktikeste järgi, mille vahe on 10 mm. 

 

 

 

Edasi panna paika töölaua nullpunkt. Vali CAM menüüst 

WORKPIECE ZEROPOINT (WZP). Liigu töölaua 

vasakusse alumisse nurka ja jäta horisontaalse ja 

vertikaalse töölaua serva vahele 10 mm ruumi, et  näha 

nullpunkti asukohta, kliki.  Nüüd  tekib horisontaalses ja 

vertikaalses suunas valge joon ja nende ristumiskohas 

valge ringjoon - töölaua nullpunkt punkt 5..  

 

Nihuta tekkinud pilt  nurka 

pidi nullpunkti. Vali menüüst 

Edit tööriist SHIFT.  Liigu 

joonise vasakusse nurka punkt 

6., kliki. Liigu pildi paremasse 

ülemisse nurka punkt 7.,tee 

teine klikk, pilt muutub 

negatiivseks. Seejärel teha uus 

klikk  punktis 6.: haara kinni 

pildist ja liigu hiirega 

nullpunkti. Kliki punktis 5., 

pilt liigub nurka pidi 

nullpunkti. Pilt on nüüd õige 

koha peal 

Enne joonestamise algust muuta hiire 

liikumine töölaual sujuvaks. 

 

4. 

3. 

6. 

7. 

5. 



 

Ava menüü Settings valik RULER/GIRD/CATCH, pärast 

klikki avaneb uus aken. 

Eemalda linnuke CATCH menüü osas. Linnuke laseb 

liigutada ainult 10 mm kaupa. Vajuta OK. 

 

 

 

 

 

 

 

 

 

 

 

Kuna tegemist on väikese joonisega, siis on vajalik 

joonist ekraanil suurendada. Vali View menüüst 

CHOOSE DETAIL, märgi pilt. 

 

Märkimiseks kliki pildi 

parema ülemise nurga 

juures punkt 8. 

Liigu hiirega vasakusse 

alumisse nurka 

nullpunkti -  punkt 9., 

kliki. Pilt muutub suureks. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Pildi üle joonestamine 

 

Vali menüüst CAD standard 

tööriist POLYGON. 

 

Mine pildi serva juurde, kliki punktis 10, liigu edasi, 

tee teine klikk punktis  11, kolmas klikk punktis 12. 

Jätka mööda serva klikkimist, kuni kogu joonise serv 

on üle joonestatud. 

 

 

8. 
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Vaheta suurendatud pilt uuesti 

tavavaate vastu. 

 

Ava View menüü ja vajuta nupule 

TABLE VIEW.  

 

Kirja saamiseks  

ava CAD standard menüü ja vajuta nupule 

ENGRAVINGTEXT max/sl. 

 

Liigu hiirega teksti kirjutamise algpunkti ja kliki 

punktis 14.  

Avaneb teksti redigeerimise aken. 

 

Vali sobilik kirjastiil, hetkel on KOSY. 

Point  - kirjasuurus 14. 

Text slopong (-45 – 45) võimalus kallutada kirja 45 

kraadi paremale või vasakule. 

Range(1 – 63)  - tähtede vahekaugus. 

Viimane rida on sisestatava teksti tarvis: BATMAN 

Kõik seadistatud, vajuta OK. 

 

Joonisele ilmub kiri BATMAN. 

 

Vajaduse korral saab teksti redigeerida. 

 

Ava Edit menüü ja vajuta tööriistale EDIT TEXT. 

Liigu hiirega kirja alguspunkti 14., oota hetk, kiri muutub 

punaseks. Kliki hiirega, avaneb teksti redigeerimisaken, 

kus saab teha parandused. 

Vajuta OK.  

 

Lisa freesimistehnoloogiad: graveerimine ja väljalõikamine. Kõigepealt lisa väljalõikamise 

tehnoloogia, kuna seda teeb pink viimasena, seejärel graveerimise 

tehnoloogia. 

 

Väljalõikamise tehnoloogia lisamine 

 

Ava menüü CAM tööriist TECNOLOGY. 

Liigu hiirega joonise alumises servas oleva 

musta täpini punktis 15. Tee täpi peal klikk, 

liigu joonisest eemale ja tee teine klikk 

punktis 16.. Avanenud aknas, lisa 

freesimiseks sobilikud parameetrid. 

 

 

 

 

 

14. 

15. 

16. 

17. 

14. 



 

Graveerimise tehnoloogia lisamine 

 

Liigu hiirega joonise kirja juures oleva musta täpini punktis 14. Tee täpi peal klikk ning 

liigu joonisest eemale, tee teine klikk punktis 17. Avanenud aknas lisa freesimiseks 

sobilikud parameetrid. 

Pärast  tehnoloogiate paikapanemist tuleb freesimist simuleerida, et näha, kas kuskil ei ole 

tekkinud mõnda viga. 

 

 

 

 

Simuleerimine 

 

Vali menüüst Simulation => ZOOM automatic 

Avanenud aknas vajuta Yes. 

 

Kui simulatsioon on lõppenud, küsitakse, kas korrata protsessi, 

kliki No. 

 

Simulatsiooniprotsessi on võimalik 

kiirendada. 

 

Ava Parameters => Simulation => Speed. 

 

Standard Simulation'i osas saame muuta 

simulatsiooni kiirust. Vaikimisi on seal 

50%. Aeglase arvuti puhul liigutada liugur 

100% peale. Vajuta OK. Vali uuesti 

menüüst Simulation => ZOOM automatic. 

Simulatsioon toimib oluliselt kiiremini. 

 

 

 

 

 

 

 

 

Salvesta tehtud töö, vali File => Save as. Kirjuta 

aknasse töö autori nimi, vajuta OK. 

 

 

 

Seejärel avaneb uus aken, anna tööle 

nimi ja salvesta soovitud kausta, vajuta 

OK. Töö on salvestatud, nüüd jääb ainult 

freesida. 

 



 

Positiivse reljeefi joonestamine 
 

Ava Nccad7 

Ava uus joonis File => CAD/CAM Milling – new 

drawing. 

  

Pane paika töölaua nullpunkt. 

Vali tööriist CAM menüü WORKPIECE ZEROPOINT. 

 

 

 

Tee hiirega klik töölaua vasakus alumises nurgas, jättes 

nurgast kummaltki poolt 10 mm. 

 

 

Ava menüü CAD standard ja vali 

RECTANGLE. 

 

 

 

Liigu hiirega töölaua nullpunkti ja tee 

esimene klikk  punktis 1. Liigu diagonaali 

üle töölaua, tee teine klikk  punktis 2. 

Moodustub ristkülik. 

 

Vali uuesti CAD 

standard menüü ja 

tööriist 

ENGRAVINGTEXT. 

 

Liigu hiirega tekitatud 

kasti juurde, tee nullpunktist 5 mm eemal 

klikk punktis 3.. Liigu üle töölaua 

diagonaalis, tee teine klikk  5mm enne 

ristküliku nurka punktis 4.. 

 

 

 

Avanenud aknasse kirjuta soovitud tekst. 

Valida saab kirja suurust 50 Point, šrifti Arial 

Black ja kirja asukohta eelnevalt joonestatud 

ristküliku suhtes, soovitav on asetada kasti 

keskele punktid 5. ja 6. 

 

Vajuta OK. 

 

 

 

1. 

2. 

3. 

4. 

5. 6. 



 

Freesimistehnoloogia lisamine 

 

Ava menüü CAM tööriist 

TECNOLOGY. 

 

Liigu hiirega musta täpi 

juurde punktis 7., kliki, liigu eemale punkti 

8.. Tee teine klikk. 

 

Avaneb tehnoloogia aken, kus märgi 

järgnevad lahtrid: 

 

Feed(F):  100.00 (*0,1 mm/s) 

Tool diameter  2.00 (mm) 

Entire depth  2.00 (mm) 

Depth per step  1.00 (mm) 

 

Vajuta OK. 

 

Lisa teine tehnoloogia. 

Ava menüüs CAM tööriist 

TECNOLOGY. 

 

Liigu hiirega teksti ümbritseva kasti juures 

oleva musta täpi juurde. Kast muutub 

punaseks, tee hiirega klikk punktis 9. 

Liigu eemale, tee teine klikk  punktis 10.  

 

Avaneb tehnoloogia aken. 

 

Märgi järgnevad lahtrid: 

 

Feed(F)  100.00 (*0,1 mm/s) 

Tool diameter  2.00 (mm) 

Entire depth  2.00 (mm) 

Depth per step  1.00 (mm) 

 

Lisaks märgi  Technology Number, milleks 

on 1000 punktis 11. 

 

Vajuta OK. 

 

7. 

8. 

9. 

10. 

11. 



 

Simuleerimine 

 

Ava Simulatsioon => OpenGL Milling, see on 

kolmemõõtmeline simulatsioon. 

 

Ilmub allolev aken, vajuta OK. 

 

 

Kui simulatsioonis vigu ei 

tekkinud, küsib programm, kas simulatsiooni on vaja korrata, 

vasta No. 

 

 

 

 

 

Teine võimalus simuleerida 

on, kui valida Simulatsioon => ZOOM automatic. Sellisel juhul 

simuleeritakse joonist pealtvaates. 

 

Programm küsib, kas simuleerida koos Z-teljega. Vasta 

Yes. 

 

Kui simulatsioonis vigu ei tekkinud, küsib programm, kas 

on vaja simulatsiooni korrata. 

Vasta No. 

 

Salvesta töö. 

 


